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Digital Oasis Overview 

This document details the design specifications for the Digital Oasis client 
(DOC) application, a tool that enables users to easily view and manipulate 
compressed images on the Macintosh.  DOC encompasses the entire 
feature set of Harvey 1.0, and, in addition, permits users to query 
AppleSearch information sources located on remote servers. 

Since DOC functionality is a superset of Harvey, it allows users to 
efficiently "monitor" the contents of folders on their hard disks.  As files are 
added to or removed from a monitored folder, the Browser window in 
DOC updates dynamically to reflect those changes.  A user might typically 
select several thumbnails on PressLink to download to a folder on his 
Macintosh.  Once the downloading process has begun, he can switch into 
DOC, select the same folder to monitor, and view the thumbnails as they 
arrive. 

DOC also includes features that do not exist in Harvey 1.0 – specifically, 
the ability to connect to an AppleSearch server and issue a full-text query 
against one or more of the info sources contained in that server.  Once the 
query has been processed by the server, thumbnails appear in the DOC 
Browser window in relevance-ranked order.   
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Requirements Summary 

Since DOC is positioned as one of a set of tools which provide a "virtually 
integrated" environment for the user, it is crucial that DOC adhere to all 
applicable standards and conventions of the Macintosh platform. 

DOC requires a Macintosh running System 7.1 or later with QuickTime 1.6 
or later.  It is important to note that users may or may not be running the 
"drag-and-drop-aware" Finder.  This means that any operation which is 
accomplished via drag-and-drop (between DOC and other apps or DOC 
and the Finder) should have an alternate method (e.g., standard file dialog) 
for such users. 

DOC can run in a memory partition under 800K. 

DOC must yield to user events at all times.  This allows users to interrupt 
any operation that may be in process (e.g., redrawing the thumbnails in the 
Browser window). 

DOC should take advantage of direct manipulation techniques wherever 
possible to make the user's experience even more intuitive. 

DOC should allow the user to configure his own environment as much as 
possible. 

DOC must support the AXS concatenated file format with JPEG 
compression.  These AXS-type files must have a valid thumbnail as part of 
the image file (early versions may not).  Files without thumbnail data will 
require re-validation with an application utility such as IronMike Norman. 
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Human Interface Functional Specifications 

Launching DOC 

DOC can be launched from the Finder in three different ways:  opening the 
application directly, opening one or more DOC documents, and via drag-
and-drop over the application. 

When a user opens the application directly, DOC launches in the same 
configuration in which the user last left it.  This allows a user to continue 
monitoring the same set of folders in exactly the same manner as he is 
accustomed to. 

When a user opens one or more DOC documents or drags one or more 
DOC documents over the application, the appropriate project windows 
appear in front of any windows which were left open during the user's last 
session. 

When the user drags one or more folders over the application, DOC opens 
with the Info Source window in front of any windows which were left 
open during the user's last session.  The appropriate folders will appear in 
the Info Source window at the top of the list, with any other folders in the 
list deactivated (unchecked). 
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The Browser Window 

 
Figure 1.  The Browser window 

The Browser window is a configurable grid where images from the 
monitored folders (active info sources) are displayed.  There is only one 
Browser window, and it is always displayed with "Browser" in the title bar.  
Images are dynamically updated as the sources' contents change. 

JPEG support for viewing compressed images is accomplished using 
QuickTime. 

If a file in one of the active info sources does not contain a viewable 
thumbnail, the document file type icon is displayed in the cell (scaled to 
display at the current cell size). 
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Images can be dragged to Project window or Shared Services Library 
(SSL),  leaving Browser window unchanged.  The dragging operation 
follows the human interface as specified by the Apple Drag Manager 
documentation. 

The Project Window 

 
Figure 2.  The Project window 

Displays group of static images which can be saved as a Project document. 

When the user creates a new project, the window initially appears with  
"untitled" in the title bar (if there is already an "untitled" window present, 
it should be named "untitled 2", etc.). 

Once the window is saved as a Project document, the saved name appears 
in the title bar. 

Any number of project windows can be open simultaneously (constrained 
only by the memory partition that the client is running in). 

Images can be dragged from the Project window to the SSL. 

Images are added to a project by dragging them from the Browser window 
to the appropriate project window. 
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Images are removed from a project by dragging them to the Finder's Trash 
icon or by choosing "Clear" from the Edit menu. 

Images can be dragged from one Project to another leaving the first Project 
unchanged. 
Saved projects (DOC documents) containing items found on an remote 
volume will not be viewable unless that volume is mounted. 

Functionality in the Browser/Project windows 

Retention of settings between sessions: 

• window position 

• window size 

• cell size in grid (if set in Preferences) 

• information sources and their state (checked, sort) 

• list/thumb display (text list, cell list) 

Zooming  

Clicking the first time in the zoom box expands the window to the size 
of the screen that it is located on. 

Clicking again in the zoom box (if the window has not been moved or 
resized since the first click) reverses the operation. 

Clicking again in the zoom box (if the window has been moved or 
resized since the first click) expands the window to the size of the 
screen that it is located on. 

Viewing 

Images can be viewed as thumbnails or as a textual list. 

The heading are as follows: file name, creation date, file size, slug 

Sorting 

Images in the Browser or Project windows can be sorted by choosing 
"Sort…" from the Edit menu, which brings up the following dialog: 
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Figure 3.  The Sort dialog 

The user can click on the pop-up menu to choose a new sorting 
criterion, as shown below.  Note that if the user chooses "Info Source" 
as the sorting criterion, the items are sorted by relevance within each 
info source. 

 
Figure 4.  The Sort By pop-up menu 

The user can also click on the sort order button to toggle between 
ascending and descending sort order, as shown below: 

 
Figure 5.  The Sort Order button 
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Printing 

 Use a standard proofing template (8.5 x 11 paper size) which would 
offer either a horizontal or vertical grid of thumbnails with 2 or 3 lines 
of image info beneath each thumbnail.   

Always default thumbnail sizes to 128 x 128 when printing. 

Selection 

Image is selected by clicking on it once; it is deselected by shift-clicking 
on it once. 

Groups of images are selected by shift-clicking. 

2-pixel wide selection box for cells. 

Command-double-clicking on an image launches the document in its 
native application. 

Cell Sizing 

Cells can be resized by dragging the border of any cell or by choosing 
"Resize Cells…" from the Edit menu, which displays the following 
dialog: 

 
Figure 6.  The Resize Cells dialog 

The user may enter numerical values in the editable cell size fields or 
may choose a default size from the pop-up menu as shown below.  If 
"Fit to Window" is chosen, DOC calculates what the cell size would be 
to make all images fit in the current boundaries of the window.  The 
calculated size is then placed in the editable cell size fields. 
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Figure 7.  The Default Sizes pop-up menu 
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The Shared Services Library Window 

 
Figure 8.  The Shared Services Library window 

Icons are snapped to an invisible grid in the window. 

User can change the display order by moving icon to desired location. 

Icons are displayed in as many columns as the window's width allows. 

The window is scrollable and resizable. 

Zooming expands the window so that all icons or names can be viewed or, 
if that is impossible, so that the window occupies the entire length of the 
screen. 

User must be able to arbitrarily select and edit contents of SSL.  To load 
services into the window, the user may drag applications (or their aliases) 
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from the Finder into the SSL window.  Alternately, the user can choose 
"Add Service…" from the File menu to choose an application. 

To remove a service, the user may drag it from the SSL to the Finder's 
Trash icon.  Alternately, the user may select a service and choose "Clear" 
from the Edit menu. 

When an image is dragged over a service in the SSL from Browser or 
Project window, the service is highlighted. 

DOC sends an "odoc" AppleEvent message to the service when image or 
group of images are dropped on the it. 

Retention of settings between sessions 

• window visible/invisible 

• window position 

• window size 

• services and their position within the window 
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The Info Sources Window 

 
Figure 9.  The Info Sources window 

The Info Sources window displays a list view - the window is scrollable 
and resizable. 

Clicking on any of the four column headers (Active, Source, Contents, 
Location) causes the list to be sorted by that column and underlines the 
column header that was clicked on.  Clicking on the sort button toggles the 
sort order between ascending and descending. 

There can be only one reference to a particular source in the list at any 
time. 

Sources can be clicked or shift-clicked for selection and deselection. 

Sources are movable to indicate sort order of images in the Browser. 

An indicator (check mark) to the left of each source designates its status.  
Checked sources are "active" (their contents are monitored in the Browser), 
while unchecked sources are "inactive" (their contents are not monitored). 

Sources are grayed out if not available (e.g., a folder on an AppleShare 
volume that is not mounted on the user's desktop). 

To add folder sources, the user may drag folders (or their aliases) from the 
Finder into this window.  Alternately, the user may choose "Add Source…" 
from the File menu to choose a folder. 
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To remove folder sources, the user may drag folders to the Finder's Trash 
icon.  Alternately, the user may select sources and choose "Clear" from the 
Edit menu. 

Number of items is displayed beside source. 

If an info source is double-clicked, a new project window is created which 
contains all the Browser images from that source.  The title of this project 
window should be the same as the name of the selected information 
source. 

The user may choose either "Folder" or "AppleSearch Server…" from the 
Source Type pop-up menu, as shown below: 

 
Figure 10.  The Source Type pop-up menu 

If "AppleSearch Server…" is chosen, the standard PPCBrowser and 
security dialogs are displayed to allow the user to select a server and gain 
authorized access to it. 

Once the connection is complete, the server's info sources are shown in the 
window and the pop-up menu changes to include the name of the 
AppleSearch Server, as shown below: 
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Figure 11.  The Info Sources window displaying sources from an AppleSearch Server 

If "AppleSearch Server…" is chosen again, the connection with the first 
AppleSearch server is broken, and the PPCBrowser and security dialogs 
are again displayed. 

 
Figure 12.  The Source Type menu after connection to an AppleSearch Server 

The user may use the Select All menu item to select all the sources in the 
window. 

The user may use the Activate Source menu item to activate (check) the 
selected source(s). 

Retention of settings between sessions 

• window visible/invisible 
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• window position 

• window size 

• all sources - active/inactive status - position in the list 
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The Image Info Window 

 
Figure 13.  The Image Info window 

If no image in Browser/Project is selected, displays attributes (file name, 
source name, file type, file size, etc.) of the image that the cursor is moving 
over. 

If an image in Browser/Project  is selected, displays metadata (as 
unstructured text) of that image in addition to its attributes. 

If more than one image in Browser/Project  is selected, displays 
metadata/attributes of the first image that was selected. 

Support copy/paste of any text in the window. 
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Retention of settings between sessions 

• window visible/invisible 

• window position 

• window size 

• order, position of fields within window 
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The Query Palette 

 
Figure 14.  The Query Palette 

The user types in a query and hits the "Find button".  During the search 
process the curser changes to the following: 

 

The first applicable image in the frontmost image window (Browser or 
Project window) is selected.  The user can then choose "Find Again" from 
the Edit menu or from the palette to select the next found item.  Once the 
user changes the query text, the palette reverts back to its initial state. If 
nothing is found a "timed dialog" stating that fact appears for 2 seconds. 

 
Figure 15.  The Query Palette after a local "find" has been completed 

If the user chooses the "More Choices" button, the palette changes to allow 
AppleSearch queries (if a connection to an AppleSearch server has not 
been made in the Info Sources window, the More Choices button is 
disabled). 
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Figure 16.  The Query Palette after "More Choices" has been chosen 

In the "More Choices" mode of the Query Palette, the user may tab to the 
different fields of the palette in the following order: query field, rank, 
returns, month, day, and year.  When one of these fields is activated (by 
either clicking on it or tabbing to it, the contents of the field are 
highlighted.  In each case except the query field, up/down arrow controls 
are placed beside the active field.  The user may click on these arrows to 
increase/decrease the value in the field.  The user may also type a number 
(in the rank field, the numbers 1 through 5 translate to the appropriate 
number of stars in the field). 

The user's entry in the numerical fields is validated and, if necessary, 
coerced to a "legal" value.  Legal values are as follows: 1 to 5 for the rank, 1 
to 99 for the returns, and any valid date for the month/day/year. 

Preferences dialog 

Same preferences as Harvey... 
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Menus 

Apple Menu 

 
Figure 17.  Apple menu 

About Agent Orange… will bring up some snazzy dialog with a 
QuickTime video of Miles Waldron. 

File Menu 

 
Figure 18.  File menu 

New Project creates a new, untitled project window. 

Open Project… displays a standard get file dialog as shown below. 
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Figure 19.  Standard Get File dialog 

 
Close closes the active window 

Save saves the active project window 

Save As… displays a standard save file dialog as shown below. 

 
Figure 20.  Standard Save File dialog 

Clicking on the "New Folder" button in this dialog displays the "New 
Folder" dialog shown below. 
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Figure 21.  New Folder dialog 

When the user clicks on the "Create" button in this dialog, a new folder 
is created in the directory currently displayed in the save file dialog.  
The user is then returned to the Save File dialog, which now displays 
the newly created directory. 

Page Setup… displays a standard Setup dialog as shown below. 

 
Figure 22.  The Page Setup dialog 

Print… displays a standard Print dialog as shown below. 

 
Figure 23.  The Print dialog 
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Add Service… displays a get file dialog as shown in Figure 19.  When 
the user selects an application or an alias of an application, it is added 
to the Shared Services Library window. 

Add Info Source… displays a get file dialog as shown below.  When the 
user selects a folder, it is added to the Info Sources window as an active 
source.  If a folder-type info source is selected in the Info Sources 
window, this menu item changes to "Delete Info Source…".  When 
chosen, a confirmation dialog appears which asks "Are you sure you 
wish to delete the info source 'Photos Folder'?", to which the user must 
respond by clicking on the "Delete" button or the "Cancel" button. 

 
Figure 24.  Standard Get Folder dialog 

Activate Source… activates the selected source(s) in the Info Sources 
window.  This item is only enabled when the Info Sources window is 
frontmost.  This item changes to Deactivate Source… if the selected 
source(s) are already activated. 

Quit 

Edit Menu 
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Figure 25.  Edit menu 

Resize Cells… displays the Resize Cells dialog 

Find… displays the Find dialog 

Find Again  repeats the last Find command 

Sort… displays the Sort dialog 

Preferences… displays the Preferences dialog 

View 

 
Figure 26.  View menu 

by Thumbnail  - applies to the active project window or Browser 

by Name  - applies to the active project window or Browser 

Window 
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Figure 27.  Window menu 

The first four items activate the appropriate window if it is visible.  If 
not, it becomes visible and the active window. 

List of open Project windows - Selecting one of the project windows 
makes it the active window. 

The active window is checked. 

Help 

Balloon help for all menus and buttons. 

Should include all special command key sequences. 
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API Specifications 

AppleSearch Client Toolkit API 

Supported AppleEvents 

4 required events 

DOC document file format 

list of alias records? 

DOC Preferences file format 


